Cannot connect to SonicWall with any browser (TLS Support)

I cannot connect to our SonicWall NSA220-W firewalls with any browser. They all produce errors, as shown below. All the fixes I can find say “try another browser” or get on the SonicWall to change settings, but I am unable to get onto them. I tried the following Firefox changes which did not work: Also tried following and did not work: Unable to log into on-line banking account | Firefox Support Forum | Mozilla Support. Any suggestions about how to fix this?



This page can’t be displayed

Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting to https://x.x.x.x again. If this error persists, it is possible that this site uses an unsupported protocol or cipher suite such as RC4 (link for the details), which is not considered secure. Please contact your site administrator.

Secure Connection Failed

An error occurred during a connection to x.x.x.x. Cannot communicate securely with peer: no common encryption algorithm(s). Error code: SSL_ERROR_NO_CYPHER_OVERLAP

Use internet explorer.

You’ll get the error again, go to internet options, advanced tab, scroll down and enable SSL 3.0


Chrome and Firefox recently stopped supporting RC4 based certificates. Many SW self-signed certs use RC4, thus the error message you are receiving. The two simplest resolutions in this case:

  1. Upgrade SW firmware. For Gen 5 use 5.9.1.x. For Gen 6 use 6.2.4.x or later.

  2. Disable “Enable RC4-Only Cipher Suite Support” in the SW diag page. Be aware that unchecking this box might cause the sonicwall to reboot.